Chase Paymentech Settlement/Batching Disruption

Incident Report for Cybersource

Update

Cybersource continues to investigate the reports indicating a delay in settlement funding for certain transactions processed during the period of April 20–23.

Our review to date confirms that applicable settlement files were generated and transmitted successfully, and that processing completed as expected within standard timelines.

Clients who believe they may be impacted are encouraged to continue monitoring settlement activity and to contact their support representative with any questions.

We appreciate your patience and will share further updates as appropriate.

Impact: Customers may experience funding settlement issues for certain transactions processed during the period of April 20–23.

Reported Start Time: 20 April 2026

Next Update: As status changes.

We regret any inconvenience this may cause for our customers. We will provide regular updates until the issue is mitigated.

Please do not hesitate to contact the Cybersource support team if you have any questions or concerns.

Cybersource Support Center

Incident #:INC25223058
Posted Apr 24, 2026 - 23:06 UTC

Investigating

Cybersource is aware of reports indicating a delay in settlement funding for certain transactions processed during the period of April 20–23.

Our review to date confirms that applicable settlement files were generated and transmitted successfully, and that processing completed as expected within standard timelines.

Clients who believe they may be impacted are encouraged to continue monitoring settlement activity and to contact their support representative with any questions.

We appreciate your patience and will share further updates as appropriate.

Impact: Customers may experience funding settlement issues for certain transactions processed during the period of April 20–23.

Reported Start Time: 20 April 2026

Next Update: Within 60 minutes

We regret any inconvenience this may cause for our customers. We will provide regular updates until the issue is mitigated.

Please do not hesitate to contact the Cybersource support team if you have any questions or concerns.

Cybersource Support Center

Incident #:INC25223058
Posted Apr 24, 2026 - 22:22 UTC
This incident affects: Settlement/Batching (Chase Paymentech Solutions).