We have put mitigations in place and the Cybersource platform performance has returned to normal.
This issue is resolved, and we will continue to monitor closely.
Reported Start Time: 15 July 2026, 23:12 GMT Reported End Time: 16 July 2026, 08:19 GMT
Impact: Some users may have experienced payment processing error messages during the incident period, which may have temporarily affected payment processing activities. The issue has since been resolved.
Next Update: No further updates, issue resolved.
Incident #: INC26452085
Please do not hesitate to contact the Cybersource support team if you have any questions or concerns.
We have put mitigations in place and the Cybersource platform performance has returned to normal. This issue is mitigated, and we will continue to monitor closely.
Posted Jul 16, 2026 - 08:37 UTC
Update
We have put mitigations in place and are seeing performance improvements across the platform. We continue to monitor closely to ensure full resolution.
Posted Jul 16, 2026 - 08:03 UTC
Identified
We have put mitigations in place and are seeing performance improvements across the platform. We continue to monitor closely to ensure full resolution.
Posted Jul 16, 2026 - 04:46 UTC
Update
We continue to investigate the issue and working toward mitigation.
Posted Jul 16, 2026 - 04:26 UTC
Update
We continue to investigate the issue and working toward mitigation.
Posted Jul 16, 2026 - 03:23 UTC
Update
We continue to investigate the issue and working toward mitigation.
Posted Jul 16, 2026 - 02:56 UTC
Update
We continue to investigate an issue causing intermittent transaction timeouts and elevated processing latency for a subset of customers.
Mitigation activities have been implemented, and our teams are observing improvement in some transaction flows; however, recovery is not yet complete.
Customers may continue to experience intermittent transaction delays, timeouts, or processing failures while recovery efforts remain in progress.
Additional recovery actions are underway to further improve transaction processing stability and reduce customer impact.
We are actively validating the effectiveness of these mitigation measures and tracking service recovery across affected transaction flows.
Impact: Users may experience payment processing error messages.
Reported Start Time: 15 July 2026, 23:12 GMT
Next Update: Within 60 minutes
We regret any inconvenience this may cause for our customers. We will provide regular updates until the issue is mitigated.
Please do not hesitate to contact the Cybersource support team if you have any questions or concerns.
We are continuing to investigate an issue causing elevated transaction processing times and transaction timeouts for a subset of customers. Some transactions may experience delays or fail to complete processing due to timeout conditions.
We are observing signs of improvement in some transaction flows; however, recovery remains in progress and intermittent impact may continue.
Impact: Users may experience payment processing error messages.
Reported Start Time: 15 July 2026, 23:12 GMT
Next Update: Within 60 minutes
We regret any inconvenience this may cause for our customers. We will provide regular updates until the issue is mitigated.
Please do not hesitate to contact the Cybersource support team if you have any questions or concerns.