EBC "Forgot Your Password" Link Issues
Incident Report for Cybersource
Resolved
The issue affecting the Business Center has now been fully resolved. Cybersource is conducting an internal review of the events to mitigate future occurrences.

Reported Start Time: 04:30 GMT on 12 March 2024
Reported End Time: 00:17 GMT on 13 March 2024

Impact: Customers are now able to use the Business Center as normal.

Next Update: No further updates, issue resolved.

Please do not hesitate to contact the Cybersource support team if you have any questions or concerns.

Cybersource Support Center

Incident #: INC17875925
Posted Mar 13, 2024 - 01:17 UTC
Identified
We have identified the issue affecting the EBC2 "Forgot Your Password" feature and "New User Creation". We appreciate your patience as we work urgently to implement a mitigation.

Impact: Completing the EBC2 “Forgot Your Password” feature may cause you to be unable to access your account. New User Creation feature may fail.

Reported Start Time: 04:30 GMT on 12 March 2024

Next Update: Within 60 minutes

We regret any inconvenience this may cause for our customers. We will provide regular updates until the issue is mitigated.

Please do not hesitate to contact the Cybersource support team if you have any questions or concerns.

Cybersource Support Center

Incident #: EPS-26857
Posted Mar 12, 2024 - 22:20 UTC
Update
The Cybersource teams are diligently addressing the issues with the EBC2 "Forgot Your Password" feature and "New User Creation". These issues may prevent users from logging into their accounts or creating new user accounts.

Impact: Completing the EBC2 “Forgot Your Password” feature may cause you to be unable to access your account. New User Creation feature may fail.

Reported Start Time: 04:30 GMT on 12 March 2024

Next Update: Within 60 minutes

We regret any inconvenience this may cause for our customers. We will provide regular updates until the issue is mitigated.

Please do not hesitate to contact the Cybersource support team if you have any questions or concerns.

Cybersource Support Center

Incident #: EPS-26857
Posted Mar 12, 2024 - 21:16 UTC
Update
Cybersource teams are working urgently to mitigate the issues with the EBC2 "Forgot Your Password" feature and "New User Creation" which may cause users to be unable to login to their account or unable to create a new user account.

Impact: Completing the EBC2 “Forgot Your Password” feature may cause you to be unable to access your account. New User Creation feature may fail.

Reported Start Time: 04:30 GMT on 12 March 2024

Next Update: Within 60 minutes

We regret any inconvenience this may cause for our customers. We will provide regular updates until the issue is mitigated.

Please do not hesitate to contact the Cybersource support team if you have any questions or concerns.

Cybersource Support Center

Incident #: EPS-26857
Posted Mar 12, 2024 - 20:09 UTC
Update
Cybersource teams continue to investigate the EBC2 "Forgot Your Password" feature, which may cause users to be unable to login to their account. They are working urgently to mitigate the issue.

Impact: Completing the EBC2 “Forgot Your Password” feature may cause you to be unable to access your account.

Reported Start Time: 04:30 GMT on 12 March 2024

Next Update: Within 60 minutes

We regret any inconvenience this may cause for our customers. We will provide regular updates until the issue is mitigated.

Please do not hesitate to contact the Cybersource support team if you have any questions or concerns.

Cybersource Support Center

Incident #: EPS-26857
Posted Mar 12, 2024 - 19:09 UTC
Investigating
Cybersource is aware of an issue with the EBC2 "Forgot Your Password" feature, which may cause users to be unable to login to their account.

We are investigating the cause and working urgently to resolve the issue.

Impact: Completing the EBC2 “Forgot Your Password” feature may cause you to be unable to access your account.

Reported Start Time: 04:30 GMT on 12 March 2024

Next Update: Within 60 minutes

We regret any inconvenience this may cause for our customers. We will provide regular updates until the issue is mitigated.

Please do not hesitate to contact the Cybersource support team if you have any questions or concerns.

Cybersource Support Center

Incident #: EPS-26857
Posted Mar 12, 2024 - 18:06 UTC
This incident affected: Portals (Access/Login - Business Center).