Clients and merchants can access the Post Incident Report with their Support Center login credentials at the following Link
Posted Oct 09, 2025 - 09:53 UTC
Resolved
The issue affecting Business Center Reports has now been fully resolved. Cybersource is conducting an internal review of the events to mitigate future occurrences.
Reported Start Time:02 October 2025, 04:40 GMT Reported End Time: 03 October 2025,11:48 GMT
Impact: Customers are now able to use Business Center Reports as normal.
Next Update: No further updates, issue resolved.
Please do not hesitate to contact the Cybersource support team if you have any questions or concerns.
Visa is aware of a potential service disruption. We are in the initial stages of investigation and will share more information as soon as possible. We regret any inconvenience this may cause for our customers.
Posted Oct 03, 2025 - 11:01 UTC
This incident affected: Portals (Reports - Business Center).