Business Center Notification - Service Disruption

Incident Report for Cybersource

Resolved

The issue affecting the Business Center Notifications has now been fully resolved. Cybersource is conducting an internal review of the events to mitigate future occurrences.

Reported Start Time: 30 March 2026
Reported End Time: 22 April 2026

Impact: Customers are now able to receive OTPs as normal.

Next Update: No further updates, issue resolved.

Please do not hesitate to contact the Cybersource support team if you have any questions or concerns.

Cybersource Support Center

Incident #: INC25157392
Posted Apr 24, 2026 - 01:01 UTC

Monitoring

Cybersource is aware of an issue which affected the Business Center Notifications. We have identified recent notifications as delayed messages from previously initiated actions that were processed later than expected.

We are monitoring closely to ensure the issue is resolved.

Impact: Some merchants may receive delayed One‑Time Password (OTP) / CyberSource Identification Code notifications related to earlier actions.

Reported Start Time: 20 April 2026

Next Update: As current status changes.

We regret any inconvenience this may cause for our customers. We will provide regular updates until the issue is mitigated.

Please do not hesitate to contact the Cybersource support team if you have any questions or concerns.

Cybersource Support Center

Incident #: INC25157392
Posted Apr 22, 2026 - 00:31 UTC
This incident affected: Portals (Access/Login - Business Center).