Business Center OTP Service Disruption

Incident Report for Cybersource

Resolved

The issue affecting the Business Center has now been fully resolved.

Reported Start Time: 20:01 GMT , 22 January 2026
Reported End Time: 03:15 GMT, 23 January 2026

Impact: Customers are now able to use the Business Center as normal.

Next Update: No further updates, issue resolved.

Please do not hesitate to contact the Cybersource support team if you have any questions or concerns.

Cybersource Support Center

Incident #: INC23756851
Posted Jan 23, 2026 - 07:25 UTC

Identified

Cybersource is aware of an issue that is currently affecting the login process for Business Center. Multiple merchants may experience delays or may not receive the One-Time Passcode (OTP) needed for EBC login or password resets.

We have identified this as an issue related to a vendor outage. Our team is actively working with vendor to resolve the email delivery problem.

Impact: Users may be unable to login into Business Center portal.

Reported Start Time: 22 January 2026 at 19:33 GMT

Next Update: As current status changes.

We regret any inconvenience this may cause for our customers. We will provide regular updates until the issue is mitigated.

Please do not hesitate to contact the Cybersource support team if you have any questions or concerns.

Cybersource Support Center

Incident #: INC23756851
Posted Jan 22, 2026 - 22:18 UTC
This incident affected: Portals (Access/Login - Business Center).