Business Center Transaction Search and Case Manager Service Disruption

Incident Report for Cybersource

Update

A fix has been implemented and we are monitoring closely to ensure the issue is resolved.

Impact: The issue has been mitigated and customers are now able to use the Business Center for Transaction Search and Case Manager as expected.

Reported Start Time:24 November 2025
Reported End Time: 27 November 2025

Next Update: As current status changes.

Please do not hesitate to contact the Cybersource support team if you have any questions or concerns.

Cybersource Support Center

Incident #: INC23040111
Posted Nov 29, 2025 - 00:37 UTC

Monitoring

A fix has been implemented and we are monitoring closely to ensure the issue is resolved.

Impact: The issue has been mitigated and customers are now able to use the Business Center for Transaction Search and Case Manager as expected.

Reported Start Time:24 November 2025
Reported End Time: 27 November 2025

Next Update: As current status changes.

Please do not hesitate to contact the Cybersource support team if you have any questions or concerns.

Cybersource Support Center

Incident #: INC23040111
Posted Nov 27, 2025 - 18:23 UTC

Update

We are receiving reports of latency for Transaction Search and Case Manager. We are continuing to investigate and are working urgently to resolve the issue.

Impact:Merchants may have experienced intermittent missing transactions or slow searches in Transaction Search and Case Management.

Reported Start Time: 24 November 2025

Next Update: As status changes or additional information is provided.

We regret any inconvenience this may cause for our customers. We will provide regular updates until the issue is mitigated.

Please do not hesitate to contact the Cybersource support team if you have any questions or concerns.

Cybersource Support Center

Incident #:INC23040111 & INC23054295
Posted Nov 26, 2025 - 16:59 UTC

Update

We are observing stability for Transaction Search and Case Manager. We continue to monitor and appreciate your patience.

Impact:Merchants may have experienced intermittent missing transactions or slow searches in Transaction Search and Case Management.

Reported Start Time: 24 November 2025

Next Update: As status changes or additional information is provided.

We regret any inconvenience this may cause for our customers. We will provide regular updates until the issue is mitigated.

Please do not hesitate to contact the Cybersource support team if you have any questions or concerns.

Cybersource Support Center

Incident #:INC23040111 & INC23054295
Posted Nov 25, 2025 - 19:25 UTC

Update

Cybersource continues to investigate the issue that is currently affecting the Business Center for Transaction Search and Case Manager.

We are working urgently to resolve the issue and appreciate your patience.

Impact:Merchants may experience missing transactions or slow searches in Transaction Search and Case Management.

Reported Start Time: 24 November 2025

Next Update: As status changes or additional information is provided.

We regret any inconvenience this may cause for our customers. We will provide regular updates until the issue is mitigated.

Please do not hesitate to contact the Cybersource support team if you have any questions or concerns.

Cybersource Support Center

Incident #:INC23040111 & INC23054295
Posted Nov 25, 2025 - 14:58 UTC

Update

Cybersource continues to investigate the issue that is currently affecting the Business Center for Transaction Search and Case Manager.

We are working urgently to resolve the issue and appreciate your patience.

Impact:Merchants may experience missing transactions or slow searches in Transaction Search and Case Management.

Reported Start Time:24 November 2025

Next Update: As status changes or additional information is provided.

We regret any inconvenience this may cause for our customers. We will provide regular updates until the issue is mitigated.

Please do not hesitate to contact the Cybersource support team if you have any questions or concerns.

Cybersource Support Center

Incident #:INC23040111
Posted Nov 24, 2025 - 17:22 UTC

Investigating

Cybersource is aware of an issue that is currently affecting the Business Centerfor Transaction Search and Case Manager.

We are investigating the cause and working urgently to resolve the issue.

Impact:Merchants may experience missing transaction or slow searches in Transaction search and Case Management Search.

Reported Start Time:24 November 2025

Next Update: Within 60 minutes

We regret any inconvenience this may cause for our customers. We will provide regular updates until the issue is mitigated.

Please do not hesitate to contact the Cybersource support team if you have any questions or concerns.

Cybersource Support Center

Incident #:INC23040111
Posted Nov 24, 2025 - 16:28 UTC
This incident affects: Portals (Case Management Search - Business Center, Transaction Search - Business Center).