Business Center Service Disruption

Incident Report for Cybersource

Postmortem

Clients and merchants can access the Post Incident Report with their Support Center login
credentials at the following link.

Post Incident Report

Posted Apr 25, 2025 - 23:46 UTC

Resolved

The issue affecting the Business Center has now been fully resolved. Cybersource is conducting an internal review of the events to mitigate future occurrences.

Reported Start Time:24th April 02:24 GMT
Reported End Time:24th April 16:55 GMT

Impact: Customers are now able to use the Business Center as normal.

Next Update: No further updates, issue resolved.

Please do not hesitate to contact the Cybersource support team if you have any questions or concerns.

Cybersource Support Center

Incident #:INC20592422
Posted Apr 24, 2025 - 17:14 UTC

Investigating

Cybersource is aware of an issue that is currently affecting Business Center logins for some merchants and partners.

We are investigating the cause and working urgently to resolve the issue.

Impact:

Some merchants may experience issues logging into EBC. Affected users might encounter an authentication failure message during the login process.

Reported Start Time: 24th April 3:24 AM GMT

Next Update: Within 60 minutes

We regret any inconvenience this may cause for our customers. We will provide regular updates until the issue is mitigated.

Please do not hesitate to contact the Cybersource support team if you have any questions or concerns.

Cybersource Support Center
Posted Apr 24, 2025 - 16:07 UTC
This incident affected: Portals (Access/Login - Business Center).